My Account Portal Unavailable
Incident Report for Zetta Status Page
Resolved
Access to the My Account portal has been restored.
Posted Feb 26, 2020 - 13:12 AWST
Investigating
We're currently experiencing a disruption preventing customer access to the My Account Portal. We expect this to be resolved shortly.
Posted Feb 26, 2020 - 12:31 AWST
This incident affected: Global (MyAccount Portal (account.zettagrid.com)).