My Account Portal Unavailable
Incident Report for Zetta Status Page
Resolved
This incident has been resolved.
Posted Feb 27, 2020 - 05:14 AWST
Investigating
We're currently experiencing a disruption preventing customer access to the My Account Portal and currently investigating the issue.
Posted Feb 27, 2020 - 04:10 AWST
This incident affected: Global (MyAccount Portal (account.zettagrid.com)).